Disruption of Hardware Orders and New Software Orders

major icon Major
Hardware and Software Procurement icon
Hardware and Software Procurement
Investigating icon Investigating

Incident timeline

major icon Major

Investigating - Ingram Micro our primary distributor for hardware and SaaS solutions is currently experiencing a cybersecurity incident. We are currently working to re-route placed orders through alternative channels.

Affected:
Hardware and Software Procurement icon
Hardware and Software Procurement